Magento – Datenimport von Artikeln Problem, dass die Artikel nicht angezeigt werden

Bei Magento 1.5.1.0 fiel auf, dass bei einem Import von Produktdaten bzw. Artikeln der Import zwar klappte und die Daten anschließend auch wieder zu exportieren waren, jedoch weder im Front- noch Backend angezeigt wurden.

Dies lag in diesem Fall daran, dass nur Produkte angezeigt werden (im Backend), die im Import das Feld für „Artikel aktiviert / deaktiviert“ haben. Wird das Feld nicht importiert, wird der Artikel im Backend nicht angezeigt. Es MUSS also dieses Feld übergeben werden. Ob nun aktiviert oder deaktiviert ist egal.

Hat man also vergessen das Feld zu importieren, können die gerade importierten Artikel wieder exportiert werden, das fehlende Feld hinzugefügt und dann wieder importiert werden.

Dann sollte es alles klappen.

Genutzt in Magento Version 1.5.1.0 Kommentare? Ergänzungen? Hinweise? Gerne!

Published by Covos

Seit 2009 arbeite ich nun intensiv mit Magento. Begonnen habe ich mit der Erstellung und dem Betrieb von B2C-Shops. Ausgeweitet wurde dies durch meine Tätigkeit im Logistik-Sektor. Hieraus entstanden erste spezialisierte B2E-Systeme. Heute arbeite ich tag-täglich mit spannenden B2C-, B2B- und B2E-Projekten und berichte in diesem Blog über Herausforderungen und gebe Insider-Tipps.

3 comments on “Magento – Datenimport von Artikeln Problem, dass die Artikel nicht angezeigt werden”

    1. Hallo Zusammen,

      auch wenn dieses Thema schon älter ist, so hat es mit bei Version 1.9.1 Magento Community gerade geholfen. Das Feld im CSV file ist unter status zu finden. Hier ist zwingend geboten aktiviert oder deaktiviert einzutragen. Ohne Eintrag sieht man die Artikel nur nach dem Import innerhalb der Ansicht Artikel in dieser Kategorie – nicht jedoch beim Artikelstamm selbst. Nachdem ich alle Artikel auf aktiviert gesetzt und sie neu importiert habe waren sie sichtbar.

      Danke für den tollen Hinweis!

  1. Nach 3 Tagen Dauer- Import haben wir festgestellt, dass Artikel, die ohne Fehlermeldung beim Import weder im Backend noch im Export vorhanden sind, aufgrund der Zeichencodierung nicht importiert werden. Auch das Speichern der CSV in anderen Codierung brachte keinen Erfolg.
    Lösung: Ersetzt alle „ä,ö,ü,ß,á,à,%,&“ durch entsprechende Alternativen und alle Artikel werden importiert.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.